Discussion:
Chrome: Kopfhörer gewechselt - Ton weg
(zu alt für eine Antwort)
Helmut Waitzmann
2017-08-03 15:31:41 UTC
Permalink
Chrome 60.0.3112.78 64 Bit auf Windows 7 Pro. Gegeben sei eine Website
mit Ton. Wenn ich jetzt den Kopfhörer abstöpsele und durch einen
anderen ersetze, ist der Ton weg.
Und wie Du inzwischen hinzugefügt hast, auch, wenn Du denselben
Kopfhörer wieder einstöpselst.
Er lässt sich auch nicht durch mehrmaliges Ein- und Ausstöpseln
von Kopfhörern wieder herstellen. Systemklänge werden aber nach
wie vor über Kopfhörer wiedergegeben.
Da dieser Effekt auch noch bei einem anderen Rechner und auch bei
Chrome auftritt: An welcher Einstellschraube in den
Chrome-Eigenschaften sollte ich drehen, damit dieser Effekt
verschwindet?
[ Erklärung jack sensing ]
Es handelt sich um den rückwärtigen Ausgang, der eigentlich für
Lautsprecher gedacht ist (Lautsprecher verwende ich zzt. keine). Den
Kopfhöreranschluss an der Vorderfront kann ich wegen Wackelkontakts
nicht benutzen und funktioniert auch nur, wenn ich zusätzlich noch das
Mikro einstecke.
[ Abhilfe durch Reset? ]
Was muss ich tun, um einen solchen Reset durchzuführen?
Wie gesagt: Reine Spekulation.
An meinem Rechner hat die Soundkarte keine solche
Wenn ich unter Linux mit einem vernünftigen
Soundkartenmixerprogramm an die Soundkarte rangehe, habe ich hier
die Möglichkeit, einzustellen, ob die blaue Buchse eine
Line-In-Buchse oder eine Rear-Out-Buchse sein soll. Ich könnte
mir vorstellen, dass es bei einer Soundkarte mit Automatik möglich
ist, mit dem Soundkartenmixerprogramm die Automatik abzuschalten
und statt dessen von Hand selber auszuwählen, was man will.
Eine solche Software lag meinem Rechner damals auch bei. Aber die
läuft nur unter XP und nicht unter Windows 7, wie ich gestern leider
feststellen durfte. Auf meinem andern Rechner, auf dem ich Manjaro
Linux habe, habe ich beim Chrome einen Tontotalausfall erlebt, der
sich nicht durch Ab- und Anstöpseln des Kopfhörers (weder von den
Frontbuchsen noch rückwärtigen Buchsen) nicht beheben ließ. Ich gucke
da mal nach, ob für meine Distri Ein Soundmixerprogramm verfügbar ist.
Bei meinem Debian verwende ich folgende Programme:

* »amixer«, ein nicht-interaktiv zu verwendendes Programm: Man
gibt ihm per Aufrufparameter (auch bekannt unter dem Namen
Kommandozeile) mit, was es an der Soundkarte verstellen oder von
ihr erfragen soll. Das tut es dann und beendet sich.

Beispielsweise zeigt mir für die blaue Buchse an der Soundkarte

$ amixer -- sget 'Line-In Mode'
Simple mixer control 'Line-In Mode',0
Capabilities: enum
Items: 'Line-In' 'Rear Output'
Item0: 'Line-In'

und

$ amixer -- sset 'Line-In Mode' 'Rear Output'
Simple mixer control 'Line-In Mode',0
Capabilities: enum
Items: 'Line-In' 'Rear Output'
Item0: 'Rear Output'

stellt mir die blaue Buchse auf »Rear Output« um.

* »alsamixer«, ein in einem Terminal (beispielsweise eine
virtuelle Konsole oder ein Terminalemulator auf der grafischen
Oberfläche) interaktiv zu verwendendes Programm, das mir
Schieberegler und Schalter zeigt, die ich mit der Tastatur
bedienen kann.

Da heißt der die Funktion der blauen Buchse betreffende Schalter
ebenfalls »Line-In Mode«.
Hat Windows kein Programm, mit dem man die Soundkarteneinstellungen
von Hand verändern kann? Vielleicht findet sich in den
Systemsteuerungen irgendwo etwas?
Da ist mir aufgefallen, dass die rückwärtigen Buchsen als
Lautsprecherbuchsen angesehen werden. Es ist nicht möglich, sie als
Kopfhörerbuchsen umzudefinieren.
Wie unterscheiden sich Lautsprecher- von Kopfhöreranschlüssen?
Ich habe bisher gedacht, das ist dasselbe: in beiden Fällen in der
Lautstärke regelbare Tonausgabe mit nicht zu hohem
Innenwiderstand. Weißt Du da mehr?
Falls bei meinem Rechner "jack sensing" existiert, liegt darin
wohl der Grund, warum ich den Ton manchmal nur über Ab- und
Anstöpseln des Kopfhörersteckers zum Laufen kriege. Beim
Windowsrechner habe ich in einem Fall die Kopfhörer dadurch
wieder zum Laufen gekriegt, indem ich F5 gedrückt habe.
Aber vielleicht sollten wir die Diskussion lieber nach
»de.comp.audio« verlagern? Ich vermute, dort weiß man besser
bescheid.

Ich mache mal ein Crossposting mit Followup-To: de.comp.audio

Falls nicht gewünscht, ignoriere es.
Richard Fonfara
2017-08-04 15:34:39 UTC
Permalink
Post by Helmut Waitzmann
Chrome 60.0.3112.78 64 Bit auf Windows 7 Pro. Gegeben sei eine Website
mit Ton. Wenn ich jetzt den Kopfhörer abstöpsele und durch einen
anderen ersetze, ist der Ton weg.
Und wie Du inzwischen hinzugefügt hast, auch, wenn Du denselben
Kopfhörer wieder einstöpselst.
Er lässt sich auch nicht durch mehrmaliges Ein- und Ausstöpseln
von Kopfhörern wieder herstellen. Systemklänge werden aber nach
wie vor über Kopfhörer wiedergegeben.
Da dieser Effekt auch noch bei einem anderen Rechner und auch bei
Chrome auftritt: An welcher Einstellschraube in den
Chrome-Eigenschaften sollte ich drehen, damit dieser Effekt
verschwindet?
[ Erklärung jack sensing ]
Es handelt sich um den rückwärtigen Ausgang, der eigentlich für
Lautsprecher gedacht ist (Lautsprecher verwende ich zzt. keine). Den
Kopfhöreranschluss an der Vorderfront kann ich wegen Wackelkontakts
nicht benutzen und funktioniert auch nur, wenn ich zusätzlich noch das
Mikro einstecke.
[ Abhilfe durch Reset? ]
Was muss ich tun, um einen solchen Reset durchzuführen?
Wie gesagt: Reine Spekulation.
An meinem Rechner hat die Soundkarte keine solche
Wenn ich unter Linux mit einem vernünftigen
Soundkartenmixerprogramm an die Soundkarte rangehe, habe ich hier
die Möglichkeit, einzustellen, ob die blaue Buchse eine
Line-In-Buchse oder eine Rear-Out-Buchse sein soll. Ich könnte
mir vorstellen, dass es bei einer Soundkarte mit Automatik möglich
ist, mit dem Soundkartenmixerprogramm die Automatik abzuschalten
und statt dessen von Hand selber auszuwählen, was man will.
Eine solche Software lag meinem Rechner damals auch bei. Aber die
läuft nur unter XP und nicht unter Windows 7, wie ich gestern leider
feststellen durfte. Auf meinem andern Rechner, auf dem ich Manjaro
Linux habe, habe ich beim Chrome einen Tontotalausfall erlebt, der
sich nicht durch Ab- und Anstöpseln des Kopfhörers (weder von den
Frontbuchsen noch rückwärtigen Buchsen) nicht beheben ließ.. Ich gucke
da mal nach, ob für meine Distri Ein Soundmixerprogramm verfügbar ist.
* »amixer«, ein nicht-interaktiv zu verwendendes Programm: Man
gibt ihm per Aufrufparameter (auch bekannt unter dem Namen
Kommandozeile) mit, was es an der Soundkarte verstellen oder von
ihr erfragen soll. Das tut es dann und beendet sich.
Beispielsweise zeigt mir für die blaue Buchse an der Soundkarte
$ amixer -- sget 'Line-In Mode'
Simple mixer control 'Line-In Mode',0
Capabilities: enum
Items: 'Line-In' 'Rear Output'
Item0: 'Line-In'
und
$ amixer -- sset 'Line-In Mode' 'Rear Output'
Simple mixer control 'Line-In Mode',0
Capabilities: enum
Items: 'Line-In' 'Rear Output'
Item0: 'Rear Output'
stellt mir die blaue Buchse auf »Rear Output« um.
* »alsamixer«, ein in einem Terminal (beispielsweise eine
virtuelle Konsole oder ein Terminalemulator auf der grafischen
Oberfläche) interaktiv zu verwendendes Programm, das mir
Schieberegler und Schalter zeigt, die ich mit der Tastatur
bedienen kann.
Da heißt der die Funktion der blauen Buchse betreffende Schalter
ebenfalls »Line-In Mode«.
Hat Windows kein Programm, mit dem man die Soundkarteneinstellungen
von Hand verändern kann? Vielleicht findet sich in den
Systemsteuerungen irgendwo etwas?
Da ist mir aufgefallen, dass die rückwärtigen Buchsen als
Lautsprecherbuchsen angesehen werden. Es ist nicht möglich, sie als
Kopfhörerbuchsen umzudefinieren.
Wie unterscheiden sich Lautsprecher- von Kopfhöreranschlüssen?
Ich habe bisher gedacht, das ist dasselbe: in beiden Fällen in der
Lautstärke regelbare Tonausgabe mit nicht zu hohem
Innenwiderstand. Weißt Du da mehr?
Ich habe eben mal nachgemessen: Bei meinem Kopfhörer haben die einzelnen
Systeme einen Widerstand von ca. 40 Ω, beim Headset ist der Wert in etwa
der 10-fache. Der Eingangswiderstand des Lautsprecherverstärkers liegt
wohl wesentlich höher, ich schätze, ca. 1 MΩ.
Post by Helmut Waitzmann
Falls bei meinem Rechner "jack sensing" existiert, liegt darin
wohl der Grund, warum ich den Ton manchmal nur über Ab- und
Anstöpseln des Kopfhörersteckers zum Laufen kriege. Beim
Windowsrechner habe ich in einem Fall die Kopfhörer dadurch
wieder zum Laufen gekriegt, indem ich F5 gedrückt habe.
Aber vielleicht sollten wir die Diskussion lieber nach
»de.comp.audio« verlagern? Ich vermute, dort weiß man besser
bescheid.
Ich mache mal ein Crossposting mit Followup-To: de.comp.audio
Ok.
--
Freundliche Grüße

Richard Fonfara
Loading...